Vultr server has 100% CPU utilization deployed with Strapi v4

I recently provisioned a new server using Vultr provider.

For a few days all is ok and no issues with the initial deployment of Strapi v4.

Just today after a quick check – the server CPU hits at 100% on the monitoring screen. as shown below:

I can access Strapi v4 api and admin client just fine. however the front-end of my app shows timeouts when attampting to connect to the API of Strapi.

Please help

Carlo M\

Hello @Karlomac01,

Try cleaning the disk space. On the server list, click the ellipsis icon for the server with the issue, then click on Clean disk space. Clean the disk space and check the monitoring and let us know if that freed up space.

If MySQL is being used, my guess is the bin logs.

It made no difference – still the same 99& CPU utilization and 30% memory.

This has been consistent when i destroy and create a new cleavr server . and deploy strapi

after a few days it goes into 100% CPU Utils.

Do yuou think i should remove MY SQL and replace with MARIADB?

Karlo M.

Ah! Sorry, I was totally reading this as disk space issue. The memory issue we have seen with some 2-core servers where 1 core doesn’t want to run correctly.

I took a look and this was the issue, you can see if in the NodeJS heartbeat where you can see one of the core processes constantly restarting. I updated the PM2 ecosystem file to use 1 core and that seems to have resolved it.

We’re looking into why this issue is happening for some apps.

One recent customer did mention that updating the entry point from npm to the path to the js app worked for them.


can you please expand on this more:

" One recent customer did mention that updating the entry point from npm to the path to the js app worked for them."

not sure how this is done -

Thank you for sorting out the issue as always – its important to get the cluster CPU working since it would not be worth using a VPS if we cant consume all of its power and resources.


Karlo M.

Aha! This is definitely some issue with Node v16 and PM2. We’ll need to see if we can resolve that. It works fine on multiple cores for v14.

The work around was to point the Entry Point to something like node_modules/strapi/bin/strapi.js; but it’s not preferable and not sure what impacts there might be.

Hmmm – thats cool – let me see if i can run Strapi v4 on Node v14 – from what i recall it needs v16 - if it can then i can keep that config until a viable solution is created. Strapi v3 and v4 is so different in accessing its api its hard to move an app built on v3 to v4 easily.

thanks for the effort -


Karlo M

Hi @amiedema

I created a new VPS with dual vCPUs and reinstalled the Strapi v4 with “instances”:“Max” and “exec_mode” : “cluster_mode” which should max the CPU immediately after install. having changed the Node v16 to v14 before i deployed Strapi v4 - There are no high CPU utilisation – and memory use is minimal –

So far strapi v4 seem to be working ok under Node 14.x . I will continue to test this config in the next few days and post an update on how its working.


Karlo M

1 Like

Hi @amiedema ,

I’m having the same issue: when deploying it start up 3 processes and just one works so it keeps restarting… What can I do about it?

Hello @tombaboon,

I’d suggest the same work around for now, which is to uninstall Node 16 and then install Node 14. We’re researching why it’s not working correctly for Node 16, but haven’t come across anything informative yet.

If changing the Node version doesn’t work, let me know. There is another workaround I can share.

Hi @amiedema,

Yes what worked for me is to unistall and install node 14. After that I need to set fork mode for the applications and set the CPU to 1. With 3 CPU it isn’t working.

Hello @tombaboon,

Are you saying running cluster mode on Node 14 didn’t work? Node 14 has worked for me with cluster mode. Can you give it another try?

I tried but when I do it with 3 cpu cluster mode the webapp can’t restart because it gave port already is use everytime

I’m seeing the exact same issue on my side with node 16 and strapi deployed with cleavr. Usage locked at 100%. It is temporarily solved by using node 14, but looking forward to a more permanent solution so that I can use v16.

We have a fix coming shortly within the next day or two. Just working on some final QA. :wink:

1 Like have fixed this issue across all NodeJS SSR type apps. Please let us know if you continue to see this issue. Also, if your deployment fails at Activate Step, please reach out.