Ubuntu Permission denied (publickey) ssh from macos [ SOLVED by amiedema ]

Trying to follow crearing a free oracle server but i gget: ubuntu Permission denied (publickey)

Just to let you know, i suck when it comes to ssh keys. I really don’t know how it works.

I regenerretad a new one on my mac so i guess i have broken all other connections with like github and cleavr?

Please adwise

Hey @peterc

That is a tricky part of the instruction. For this setup, it’s not a key-pair that will be added on your PC and the server, but on Cleavr and the server.

Step: Add a new API key VPS Profiles - Cleavr docs

For this step, do the following:

  1. Select option to generate the new API pair
    CleanShot 2022-03-11 at 08.29.52
  2. Click on ‘Download Private Key’ - remember where private key downloads to on your device
  3. Click the Add button
  4. You’ll then see the fingerprint ID

In Cleavr, you’ll need the private key and the fingerprint id from above. Find the private key file that was downloaded during steps above and add the full contents into ‘Private Key’ text area in Cleavr.

CleanShot 2022-03-11 at 08.36.28

Hope that helps!


They seems to have big problems with verifying creditcards cause i cant even sign up :frowning:

Yea - I experienced the same issue at one point as well…

@amiedema Oracle has amazing support, they fixed my account so now when i woke up (7AM in Sweden) it’s all good and i will start your tutorial again. Just wish the SSH steps were more clear in the video. I guess the key you pasted in the video is that one from “Download private key” right?

I will let you know about my progress.

I guess you are sleeping now so god morning to you when you wake up :slight_smile:

@amiedema i’m in big trouble an stuck again :frowning:

In the step where one has to ssh into the ubuntu on oracle i get:

peter@Mac-mini-work ~ % ssh ubunutu@
The authenticity of host ' (' can't be established.
ED25519 key fingerprint is SHA256:C4tpWkuittrEIcj+1WQTgZYJi88JLtZotwRuBaiyL4s.
This key is not known by any other names
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added '' (ED25519) to the list of known hosts.
ubunutu@ Permission denied (publickey).
peter@Mac-mini-work ~ % 

I have search for hours since this oriblem started yesterday but i cant find any solution.

This time i guess that the SSH problem is between my Mac and oracle?

Please adwise :slight_smile:

Hello @peterc,

Did you add your device public key to the oracle server?

@anish this is the problem i cant ssh into ubuntu so how can i add it?

IN Hetzner i could open a terminal and run commands like the one i have to run while provisioning a oracle server but i cant ssh into it. i have tryed frrom other computers.

Did i miss anything in the unstructions above while creating the vm on oracle. i downloaded the private key but i just left it on my mac. Should i have done something more in that step?

in the video there is not the same content that i get in the key i downloaded from oracle

I see this on my oracle insstance but i dont know how to move on:

Instance access

You connect to a running Linux instance using a Secure Shell (SSH) connection. You’ll need the private key from the SSH key pair that was used to create the instance.

Hello @peterc,

You need to do that from the Oracle UI. While creating a new VM instance there is an option to add SSH key. In there just paste the key you get from execution of this command in your device: cat ~/.ssh/id_rsa.pub (this is the deafult path).

I hope this helps. Do lets us know if this doesn’t work.

Also, if you’ve already created an instance you’ll need to search an option to Add SSH Key from the Oracle UI and do the same.

@anish so one could say that the downloading part is just for cleavr—oracle and what you told me now is for my mac—oracle?

If so i missed a step in creating the instance?

I will try and create a new one :slight_smile:

Hello @peterc,

The thing I said is for Mac - Oracle.

Give that a try and do let us know whether it works for you or not.

1 Like

sorry to bother you like this on a week end but i really need to put up some instances for super low traffic sites. I intend to create one instans for each site.

Do you know if there is a limit on free micro instances?

But i’m glad that i don’t have any hair to rip of otherwise i would cause it still wont work to ssh into oracle instance from my mac

peter@Mac-mini-work ~ % ssh ubunutu@     
The authenticity of host ' (' can't be established.
ED25519 key fingerprint is SHA256:QiXT4Vdgf+aQp9ncnbqlPWGzlUFtsacsShygK+WO3b0.
This key is not known by any other names
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added '' (ED25519) to the list of known hosts.
ubunutu@ Permission denied (publickey).

I can only think that there is something wrong with all ssh files on my computer. I will be happy to give you what you need to try from you computer.

Please help me as my customer expect the site to be up and running on monday :disappointed_relieved:

Hello @peterc,

I don’t see any other reason for server refusing to connect to your device if you do this as said here in this link: Launch a FREE Oracle Cloud VPS Server with Cleavr - YouTube

If that is exactly what you’re doing we should be looking after other things that may cause this.

And as far as the instance limitation is concerned I’m not sure about it so you may have to browse through Oracle documentatio.

@amish please use your karate skills to figure this out :joy:

In the meen time i will try to create a new instance from a different computer MacBook Pro.

Im so scared that i will mess something up on my “main computer” regarding ssh so i destroy any critical connections i have now.

But just to be clear, in step 3 ssh i shall do two things:

  1. download the “Download private key” to use with cleavr–oracle instance
  2. run your comman on my local mac to get the public key and paste it in

Is this correct?

Again, sorry to bother you with this but googeling ubuntu Permission denied (publickey) mac gives me 515 000 results so i guess i’m not the only one frustrated.

Hello @peterc,

Follow all the steps exactly as mentioned for a new instance from the start of the video. But at this time Launch a FREE Oracle Cloud VPS Server with Cleavr - YouTube input the SSH key you get by running this command: cat ~/.ssh/id_rsa.pub

In this step while adding SSH Key don’t forget to select Paste Public Keys.

If following all these still doesn’t work we’ll try to find a different way to solve this. We can also setup a zoom meeting to figure this out.

1 Like

@anish thank you,

i will try to create a new oracle instance from a different computer and if i get the same error i’ll get back to you an maybe we can try somthing more hands on :slight_smile:

Maybe just to rule out macos if you have a Windows machine you could try to ssh into my oracle instance just to see if it works?

1 Like


It worked to ssh into ubuntu oracle from my MacBook Pro so i will try and set upp everything from there.

Thank you so much for all great support.

Have a nice week end :slight_smile:

1 Like

@anish i sent you a PM please look at it because this is going to hell due to my lack of skills

There is a limit of 2 Oracle Micro instances that are free. Keep in mind, when you first sign up to Oracle they may give you credit but the max that they offer for free is two. :slight_smile:

but my intention of using oracle free was when i only have like one html page during development and i guess i can have e few different domains pointing to either of thoose two servers?