To change the request time-out period

I tried to increase the request time-out period of my server and tried everything I could. At the moment I’m using a Digital Ocean server and I cannot increase the time. After 1min every request is timeout.
Please guide me on how to increase the request time-out period. Thank you.

Hello Sameera,

First of all, welcome to the Cleavr forum.

Did you try increasing the server timeout in your nginx configuration by going to Sites > Site Nginx Conf and update your nginx configuration as:



proxy_read_timeout 300;

proxy_connect_timeout 300;

proxy_send_timeout 300;



Here 300 refers to 300 seconds.

Also, you can check out this guide to increase the upload limit, if that is causing the issue. Increase PHP and NGINX upload limits for WordPress - Cleavr docs

yes… I did. I added like this.

http {

# Basic Settings

sendfile on;
tcp_nopush on;
tcp_nodelay on;
keepalive_timeout 650;
types_hash_max_size 2048;
# server_tokens off;

proxy_connect_timeout 600;
proxy_send_timeout 600;
proxy_read_timeout 600;
send_timeout 600;

# server_names_hash_bucket_size 64;
# server_name_in_redirect off;

include /etc/nginx/mime.types;
default_type application/octet-stream;

# SSL Settings

ssl_protocols TLSv1 TLSv1.1 TLSv1.2 TLSv1.3; # Dropping SSLv3, ref: POODLE
ssl_prefer_server_ciphers on;

but issue is not fixed… after 1 min 504 Gateway Timeout error was executed