Strapi: .cleavr.runner.js not found, rollback doesnt work, PM doesnt start

Unfortunately I have several issues with cleavr and Strapi:

The 1. deployment worked, the 2. deployment deleted or reset the DB, so that I needed to create new users, the 3. deployment and all following ones failed within the step Link Media Uploads + Activate New Deployment with the error:

[PM2][ERROR] Error: Script not found: /home/cleavr/

I tried to activate the step Copy Files, cause it is not clear which files are copied from where to where. I thought maybe cleavr.runner.js was not copied? But this just fails with ABORTED and no further error message.

I tried to rollback to the very first deployment, but here I got an immediate message Error in deployment rollback

PM2 gives me:

2023-08-18T17:42:07: PM2 log: App [] starting in -cluster mode-
2023-08-18T17:42:07: PM2 log: App [] online
2023-08-18T17:42:07: PM2 log: Stopping id:0
2023-08-18T17:42:07: PM2 log: App id:0 disconnected
2023-08-18T17:42:07: PM2 log: App [] exited with code [0] via signal [SIGINT]
2023-08-18T17:42:08: PM2 log: pid=278454 msg=process killed

Hello @Mathias,

Thanks for reporting the issue. I’m thinking it’s looking for the runner file in the wrong place - we’ll look into this to see what might have happened.

Hi Mathias,

We’ve noticed some problems with the rollback of your site and are working on solutions. We’ve made a manual fix for you, so please try it out and let us know if it works.

Hey, just tried it and I am still getting the same error: error in deployment rollback
I also tried a new deployment, but still getting the same error here too:
[PM2][ERROR] Error: Script not found: /home/cleavr/

Hello Mathias,

We apologize for the inconvenience you experienced. We hope that your app is now functioning properly.

We previously implemented a manual fix to prevent you from being blocked when this issue arose. We have now released a version that should resolve the issue. Please contact us if you experience any further difficulties.

@anish I’m facing the same issue right now. After rollback the deployment got stuck