SSL problems once again

Hey there,

we are facing ssl problems for one of our sites once again.

it seems the ssl certificates are not valid for for some of our users.

Any ideas on this?

Appreciate your help,


Hello @sebbler,

It seems to work for me.

Can there be any cache related issues?

Yeah it’s strange.

we had this problem with multiple other sites so this makes me really frustrated as i can not reproduce it alle the times but different clients come and tell me its true.

Don’t know what to do honestly. Other than deploying the app somewhere else.

The site is freshly deployt / went live on friday so there is no possibility of a cache issue i think.

Maybe you have some ssl testing tools you can check the site with oder any other possibility to look into this?

Hello @sebbler,

If the cert is installed correctly there can be the browser compatibilty issue (usually happens with old browsers), or the DNS caching issue. I’ve tried opeining your site in Safari, Firefox, and Chrome. In all the cases it worked properly.

Browsing from phone or different network works in most of the cases this happens to me because of DNS caching.

Here is a test report from Doneo

Another one from some external tools:


Also, the best way to avoid having DNS record for a domain cached by your browser is NOT opening the domain before a SSL is installed. I’ve run into this myself multiple times - I buy a domain, want to quickly check if it is online or not and end up just caching it. Instead of navigating to the domain directly, I recommend using a tool like DNS Checker, Doneo etc.

1 Like