SSL not provisioning

Hi there, I am trying to add a Wordpress site, but the process is stuck at the SSL part and shows an error, but it doesn’t show the error exactly. For the same reason, I can’t access any part of the installed site except the homepage.

Hello @aay,

That’s typically due to LetsEncrypt not being able to verify the domain when attempting to install SSL certs.

Check to make sure the A record is pointing to the server’s IP address. You can use https://dnschecker.org/#A/ to make sure the update has propagated.

If you’re using something like Cloudflare that has an option to put DNS Records behind a proxy, make sure to turn off proxy when applying SSL cert.

Also, you can always add the site first with SSL disabled and then add LetsEncrypt of a custom cert after adding the site.

Hope these suggestions help!

Hey @amiedema I’m having the same issue now too. With Cleavr 1.0 I did this tons, and also did so for the first two sites I added to my DO server on Cleavr 2.0 last week. But today, I just added a new site, the DNS record resolves fine, but the SSL cert errors out. I tried removing and adding it again, same deal. This could actually be an issue…

Hey @onetrev,

Thanks for letting me know you also are experiencing a similar issue!

I was able to see an error returned from LetsEncrypt for your site.
Verify error:No valid IP addresses found for ...

I’m guessing the IP didn’t propagate enough for LetsEncrypt to pick it up. I tried again for you and looks like it now has SSL enabled.

IP propagation typically is pretty quick these days. Cloudflare seems to do it in 10 seconds or less… But, it can take hours in some instances.

@aay - if you are still having the same issue, please send me a PM and let me know your email address and I can look up your account to see if I can find any SSL installation errors.

1 Like

I have waited for almost an hour or two at this moment, the SSL still shows an error, I have sent you a PM

Thanks @aay!

I sent you a PM - we were able to fix the issue. It appears to most likely be an issue with the VPS server located in India. It’s difficult for us to know that 100% but we haven’t come across this particular issue before.

Can confirm, seems like an issue for the VPS located in India, thanks.

2 Likes