SSL Certificate randomly not trusted

Hi there,

we had today a new issue that the SSL Certificate from Let’s Encrypt wasn’t trusted by some browsers of our clients.
They are not happy, because they are loosing customers due to that and are blaming.

It’s not for all customers, that there is a problem.

Is there another Root Certificate issue on your side? Could you please check this and get back to me or @sebbler ?

Hello @Houbsi,

We’ll look into the matter.

In the meantime, can you message me a list of a few sites having issues with SSL? Also, mention the browser.

Hello @Houbsi ,

Thank you for providing the site details through a private message.

I tried it on some web browsers like Google Chrome, Firefox, Safari, and Brave and it seem to work on all browsers.

If possible, please let us know the browser and the site which has the issue. This way, we can dig into the issue.

Or if the issue is so frequent, can you please point out the steps to reproduce so we can look into it?

If the cert install went fine then usually this happens because of DNS caching issue. When I run into this issue ( happens every now and then), I browse it from my phone with Wi-Fi turned off and mobile data turned on.

1 Like