Site is active but not running after name change


I’m putting a website live and this will be the first website I’m putting live with Cleavr! Super excited.

At the moment it says “Active” and not running, the domain is in the propagation phase so to be sure it will be live by the time the DNS updates I’ve edited my hosts file.

Unfortunately this is met with:

What is happening? Does it stay “Active” until the domain is propagated?

Seems to be working now, but the CMS is being hit with:

Looking at the application, after renaming the website it now looks like this:

There is no information there anymore. Also I’m getting bad CPU usage.

At one point it stayed at 100% usage and I only have this site running:

I wouldn’t expect one Directus install to use 67% of 2 vCPU.

Hello @Tom,

What do you want us to look at first? The deployment failing at Generate hook, the CPU usage, or 502 issues? Let’s get these sorted ones after another.

  1. 502 Error is the most important. As this will cause the website to be down on launch (it’s currently propagating).
  2. CPU usage is the second most important as the site will need to remain fast for the launch (which could happen in minutes or hours).
  3. The generate hook as I can live without a sitemap for now.

On the CPU usage it’s now at ~100%

As far as I can think 502 is probably being caused by server overload. is taking too much of resources and probably failing.

Hi @anish,

The site I only added a couple of hours ago, but the CPU usage has been a problem since 10:10AM yesterday when a new deployment of Directus happened to update the software to 9.5.1. After the suggested reboot it went to 0% for about 10 minutes, now it’s creeped it’s way up to 100%. The 502 problem didn’t actually start until I changed the name of the website. I don’t want to redeploy because I don’t want to lose my /uploads/ folder where the client has uploaded files to the CMS. The domain is still propagating so I have edited my hosts file to test that everything is working before hand. As you can see with the CMS there is also a UI glitch where no information is displayed.

If you think it’s best I change the DNS records back to their old site and tell them I will have to delay the launch of the website because of server issues, please let me know. I need to convey that to the client ASAP.

Hello @Tom,

For the 502 error on your cms, your site has been assigned one port and Webapp < Environment is using another port. Can you please check that out first and update your environment to use the port that has been assigned and re-deploy. Let’s see if that resolves the issue for you or not?

I think this should resolve the 502 issues. And then we can dig into the other issues.


I still have the 502 error here.


The UI is also broken:

Where as my other app:

The website is now live (UK) but all the images are not loading because the CMS is down. Luckily it’s using a build before I renamed the servers from the a domain to the live domain. As soon as I renamed the site, this is what happened.

Can you check your cms site once? I think it should be working now. I found an issue with the PM2 Ecosystem and fixed it for you. We’ll find a way to automate this as well while renaming a site in the days to come.

And for the UI Glitch, I’m not sure why that is happening we’ll investigate it and get it fixed.

Thanks @anish

All the client uploaded files are now missing:

I’m guessing you’re still working on that?

SSH’ed in and found the /uploads/ folder in an earlier deployment, copied it over and all seems okay. Thanks for looking into this. I do really appreciate it.

Hey @Tom,

I’m glad you found that and got it working.

Now remains the last issue with the Generate hook. Can you try re-deploying your main app and see if it works now or not?

1 Like

Hi @anish,

That is working too now, thank you very much and the CPU usage has dropped too! Thank you so much for your time and patience looking into these issues. I really appreciate the fast support and Cleavr really is amazing! You are all doing an amazing job, thank you!