Server refusing my key

Hi, I am trying to access my server via Filezilla, I followed all steps that are on the forum, but the server keeps refusing my SSH key

Hello @aay,

We will look into it to see if we can find anything wrong going on. In the mean time can you make sure that you followed this documentation: Access Server Via FTP - Cleavr docs ?

Yes, I tried this out, too.

Hello @aay ,

Did you selected the SFTP as connection type?
As shown in the screenshot below,

Yes, I did select SFTP :-/

Hello @aay,

If you are on Mac, we recommend to use “commander one” for setting up your SFTP connection which is easy to use and access. link:

If you had selected SFTP as connection type then you have to follow the correct settings:

  1. Firstly, your public ssh key ( needs to be added to the server that you’ve created inside cleavr which you can do from server>ssh keys>add a new key.
  2. For login Make sure that you’re providing the correct user to which you can gain access through cleavr your server>system users.
  3. And lastly, You have to provide the id_rsa inside the password field.

Thank you and feel free to ask any questions if you’e still having problems with setting up the connection.

I am on Windows, sorry. Besides, I have followed all steps that are on documentation on Cleavr. I am not able to access my server using SSH.

Hello @aay,

Sorry about the issues getting connected via SFTP!

Let’s first see if you can SSH into the server from your device. Since you are using Windows, we do have a guide on accessing servers using PuTTY. Have you tried going through this guide as well? Access Server Via PuTTY - Cleavr docs

My thought is there is probably some issue with the private / public keys and this should let us know if there is an issue there or not.

Yes, I was able to log in via the SSH

Perfect! That should narrow it down to the connection configs in FileZilla. Did it throw any useful errors or was just generic about not accepting SSH connection?

Please feel free to send a PM or open a support ticket and provide a screenshot of the connection configs and we can take a look to see if it looks right or not.

Sorry, I got busy, so I completely forgot. There seems to be some issue with Filezilla, I used another file manager, and I could log in.

1 Like