Quasar SSR App with my own domain name

Hi,

I have a Quasar SSR app that is able to deploy when I’m using a temporary domain from cleavr.

How do I deploy using my own domain name?

I think I’m missing a very obvious step here, but for the life of me, I can’t figure it out.

I have tried to add another site (with my domain name), deploy my SSR app, point my A record from cloudflare to Public IP of the provisioned server. But it’s either 502 error, or a Not Found exception when I try to navigate to the home page (www.numnum.me)

Any ideas?

Andy

Here is the pm2 log. Seems like the app is running then killed immediately

Hi @numnum.me,

Welcome to the cleavr forum!

I think I know what the issue might be. I’ll send you a private message.

1 Like

Hi @numnum.me

First of, nice with a fellow Quasarian :slight_smile:

I remember when i first deployed my Quasar SSR i needed to FTP in and manually add the .env file.

Not sure if this will help you but what i did was to FTP into sitefolder and looked for “missing stuff”

Have a nice day.

/Peter Sweden

2 Likes

Hi Peter,

Yes, my first app with Quasar

Adam helped me by pointing out that the NGINX config was not there. So I tried to redo the steps again (delete my deployments and sites, and re-add them) and I explicitly put my cloudflare settings to ‘DNS only’ for the Let’s Encrypt certbot to do it’s magic, and it worked.

My app is up now and I can see the NGINX config.

But thanks for your recommendation though. :slight_smile:

3 Likes

How can we get some more Quasar devs in here? They seem like good people :wink:

2 Likes