Nginx service setup remains in state "Pending"

Hi, I’ve just added a plain server and wanted to add nginx to it. The installation starts (showing me a empty json response in a white overlay screen as response) but remains in state pending - at least for 20 minutes now.
This is my second attempt. The first attempt leads to the same behavior. I resetted the server and installed Ubuntu 20.04 again - same result.

Hello @sewid,

We’ll look into the issue and get back to you.

Are you trying to provision a Custom server with Plain Server as the server type?

Ok, thanks. Yes, it was a custom server with plain server as server type.

nginx is still not installed, I clicked “check heartbeat” once with the result:

nginx: unrecognized service
tac: failed to open '/var/log/nginx/error.log' for reading: No such file or directory

We’ll need to investigate further. In the meantime, you might try removing the custom server in Cleavr and then re-setup the same server as a custom server but with an app server type that includes NGINX.

Redeploying the server as app server is working without problems.


To provide more informations, I just re-tested the plain server with installing nginx. After the plain server has been deployed, after clicking to install nginx, the following screen appears:

The error message is: All Inertia requests must receive a valid Inertia response, however a plain JSON response was received.

Maybe this helps…

Hey @sewid,

Thank you for reporting the problem. We’ve identified an issue that we suspect is causing the inertia error that you are getting.

Will roll out the new changes in the next few hours.

I’ll keep you updated.

Hello @sewid,

We just deployed a few fixes that include the NGINX issue as well.

Can you give it a try once and let us know if that resolves the issue you’re facing or not?

Hi @anish, I retried the plain server setup and added nginx manually. I was able to add nginx, but I was not able to add a site with a Lets Encrypt certificate. It always failed to add the certificate.

After that, I reinstalled the server using the app server template (that contains nginx) and everything (including Lets Encrypt certificate) was working fine. There is only one thing, that is not working - that is the web server monitoring. I reinstalled and repaired the monitoring service multiple times without success. CPU, memory, disk space and uptime gets monitoring but for the web server it shows ‘Error Fetching Web Server Data’.

Hello @sewid, can you please send a DM and let me know which server (IP address would work) this is happening on and I can take a closer look.