Next SSR, does not deploy itself

Hello guys,

I am having a slight problem with push to deploy method.

I have a number of Laravel Apps that work perfectly without any error and deploy themselves without any error on git push.

But I have a few NextJs Projects. None of them are deploying themselves with push to deploy method,

Does anyone know the reason for that?

Hello @lathindu,

Here are some things to check:

  1. In web app > settings > code repo, the ‘Push to deploy’ should be enabled. You’ll need to have necessary permissions to the repo on the VC provider to enable. If you also are the owner of the repo, there should be no issues enabling.
  2. Make sure the ‘Branch to deploy’ is also the one that is expected to be deployed via push to deploy
  3. If using Github, go to the repository > Settings > Webhooks. You should see the webhook for Cleavr here. You can check the last deliveries to see if there were errors. Also, please note that GH has a limit of number of webhooks, I think it’s 20 for free plans.

I hope the above helps but please let us know if you try them and are still stuck.

Hello @amiedema ,

Thank you for your reply.

all the 3 points are correct and checked again and again.

Also, I see, all the webhooks were also delivered and got 204.

before two/three weeks. this worked. but now it’s not.

Can you also try triggering the deployment hook?

An example of where the hook is and how to trigger is found here: Web App Settings - Cleavr docs

One more thing to try, is to disable ‘Push to deploy’ and save that setting, and then renable and then save that. This will re-add the hook to GH. then, try initiating a push to deploy and let me know if it is still failing to deploy and we can take a deeper dive.

Hey @amiedema. I can deploy manually without any issues.

these are errors that I’m facing.

01 Git Push to deploy: does not work with NextJs → [earlier worked, but not from few weeks].

02 I’m doing manual deployments by clicking the deploy button. So after clicking the “deploy” button. it’s starting the deployment. but it’s not updating the current “current state”. I have to refresh the page and see, the current state (like: copy project, Link ENV, Install NPM Packages …)

These all errors are happening with NEXTJS SSR only. [For Laravel all are working perfectly]

Thanks for the additional info! We’ll take a closer look and will let you know what we find.

Hello @lathindu, can you please go to the repo in Github, and send me the payload url for the webhook that was added by Cleavr? Please send via a private message directly to me.

Also, after sending it to me, can you also try replacing the payload url with the one that is in the deployment settings > Basic tab > Deployment Trigger Hook. After saving that, try to initiate a push-to-deploy by making an update to the repo and then let me know if that results in a deployment.

1 Like

I sent it to you @amiedema