Netdata not starting up after reboot


I’m having a problem starting netdata after i reboot my server. When the service is first installed the service starts up however if I reboot the server it doesn’t come up again.

I have tried to start the service manually but it doesn’t work either. The only way I have found to make it start again are reveting back to the snapshot from before the reboot or reinstalling the entire service which isn’t exactly good solutions.
Deploying a new server gives me the same result.

The server are running a clean Ubuntu 22.04.

Anyone else experincing this issue?

// Rasmus

Hello @fridlev and welcome to the Cleavr community!

Sorry to hear about the monitoring issue - are you still experiencing an issue?

We occasionally hear of issues after a reboot - usually involving a custom server setup as various hosting providers have their own way of doing things, even with a standard Ubuntu instance. If you’re using the custom server option, can you let us know which hosting provider you are using?

Hello and thank you! :slight_smile:

I found another way to get it up. The suitability of this solution depends on how Cleavr updates configurations.

For some reason, Netdata has a problem establishing unix:/var/run/netdata/netdata.sock on my system, so I edited my netdata.conf to bind to localhost and updated the Nginx config accordingly. Now everything is running stable, and I can reboot the server. I know using the socket would be more efficient, but it seemed like a dead end getting that to work properly.

While investigating, I noticed that Netdata was missing its index file in /var/lib/netdata/www . Do you know if it was removed or moved for security purposes? For the public, I fully understand why, but I’d like to have it served locally, and that isn’t possible without it.

Whether this is a solution or not depends on if Cleavr will push and override my config customizations.

Hello @fridlev,

We moved files from /var/lib/netdata/www to /var/lib/netdata/www/_dontserve to prevent public access to your dashboard. To re-enable access, move the files back from /var/lib/netdata/www/_dontserve to /var/lib/netdata/www .

If you need your dashboard URL or have any questions, feel free to ask.