Letsencrypt error setting up new directus instance on temp domain


I am trying to setup a new directus site on a linode instance and have tried several times now with the same error occuring.

I’m trying to install the patch / latest release of directus 10.8.3 and am following the one click install process in order to do so. Eventually the process fails after numerous attempts at

The error I keep getting is as follows:

2024/01/24 11:47:54 [error] 51467#51467: *131 cannot load certificate “data:”: PEM_read_bio_X509_AUX() failed (SSL: error:0480006C:PEM routines::no start line:Expecting: TRUSTED CERTIFICATE) while SSL handshaking, client:, server:

“/home/cleavr/ui8gh6wu2phfbz3f10421.cleavr.one/current/.well-known/acme-challenge/MGywFJ1ZcHoSaxmei3LXD1iEfqW_RykPMkgXgO20fKE” failed (2: No such file or directory), client:, server: ui8gh6wu2phfbz3f10421.cleavr.one, request: “GET /.well-known/acme-challenge/MGywFJ1ZcHoSaxmei3LXD1iEfqW_RykPMkgXgO20fKE HTTP/1.1”, host: “ui8gh6wu2phfbz3f10421.cleavr.one”


Hello @webcrown,

First of all welcome to Cleavr Forum.

We’ll look into the issue and get back to you.

Hi @anish great to be here and thank you it’s much appreciated!

Hello @webcrown,

Please attempt creating the site again and inform us if you encounter any problems.

Hi @anish

I’ve tried twice with the same error now both times which is different than before please see below:

Hello @webcrown,

Can you try installing newer version of NodeJS from the Server > Services page and try creating the site again?

You can try, NodeJS 18/20.

That worked and fixed everything thank you @anish !