Is here the place to increase nginx upload limit?

I am following this tutorial

After updating PHP, go back to the services section and select the wrench icon for NGINX.

  1. Add client_max_body_size 128m;
  2. Save file
  3. Restart nginx by clicking on the restart icon

Is my screenshot correct?
Or it mean edit nginx.conf?

Hello @mike,

For the screenshot, the first text box can be modified for client body size.

If I want the upload limit to be 2000M, should I enter 2000M or 2000m?

I’m not completely sure if it’s case sensitive; but I’d keep it lowercase since that’s usually how I see it represented. Assuming you are asking for 2000 mb.

I have changed it to lowercase.

If my phpMyAdmin keeps on timeout, what should I change in the nginx/php settings?

That’d be a combination of all the configs on Increase PHP and NGINX upload limits for WordPress - Cleavr docs. 2000 mb is quite a lot, it’d probably be quicker to establish an SSH connection and use SFTP to transfer files.

Thanks, the video on this page is very helpful

I am able to change it now.

1 Like