Error moving the upload folder to new deployed folder

Hi -

I have successfully deployed Strapi v3 for the past 3 months and now i upgraded a few features in my strapi build. however when it got to the part where it was going to copy the uploaded files from the older deployed folder it failed with the error below:

I would appreciate the help please. This is currently a live site with i need updated features


Carl M

Hello @CarloMacsett,

We apologize for the inconvenience caused.

We’ll look into the issue and get back as soon as possible.

Hello @CarloMacsett,

There was file permission issue with the uploaded files in uploads directory.

We’ve fixed the issue for you. The uploads directory had files with root permission. Do you happen to have copied the uploads folder yourself?

I dont think so…

From initial deploy , the feature of persistent file store was not implemented on cleavr as yet.

When it was, i tried to re-deploy however there was an error - to which i wrote about it on my other account (karlomac) - this is under my client’s account - i manage their deployment for them.

i did not get a chance to follow the instructions therein to manually move the files.

After i had a few upgrades to the client strapi configuration, i re-deployed and encountered the error.

It may have been created on my first attempt to use the new feature –

Thank you. I will try deploy again

Carlo M.

1 Like

@anish -

It happened again on the same deployment –

I just run deploy and it gave the same error again.

Is there is another issue?


Carlo M

Not sure why it keeps happening for your server. The issue is that some of those files are created as root user. It could be that there are some plugins that are run as root user? Anyway, the solution here is to ssh into your server and fix the permission by running the following command:

chown -R cleavr:www-data /home/cleavr/

We could do it for you but you might want to give it a try as yourself to resolve this quick if it happens again.

PS: We will continue to watch this issue and see if there are something on our side that is causing this repeatedly.

1 Like

Just a quick update – so far its not happening now – actually downgrading to node v14 seem to have solved a lot of issues in the strapi deployment – so please do consider it – im looking into using both strapi v3 and v4 under node v14 using dual vCPU and it seems to be stable –

Ive recently upgrade the builds and redeployed the a clients v4 strapi and alll went smoothly. Mind you this was after 3 rebuilds of the server. I also switched from linode to vultr – not sure if that made a difference but it seem to work better now

Just some more thoughts to consider.


Karlo M