Directus with Docker on Generic Port App

I’ve been trying to install Directs 10.8.3 using Docker in a Generic Port App. I would like to connect to a Supabase, but have also tried a SQLite config. The Supabase config exists with ERROR: Failed to sync extensions (seems it cannot create sub-directories of Extensions). The SQLite config exists with an error about connecting to the database.

What am I missing?

Thank you!

Hello @tomkenkel,

First of all, welcome to Cleavr Forum and sorry about the delayed response.

It looks like Directus 10.8.3 is their latest minor release and you should be able to install the latest minor release by selecting the Install latest minor release option from the Directus Release Version selector while adding a new site.

You need to enable Setup Database option for 1-click Directus installation to work.

I found similar issues on GitHub related to the error message you shared during a quick search.

It’s possible that you’ve already reviewed these links, but if not, they could be helpful.

Please let me know the name of your Directus app via PM and we’ll look into the issue further.

Hi Anish,
Thanks for the welcome and response.

The Cleavr installer works as expected, but I would prefer to use Directus with an external database, like Supabase. How would a Cleavr customer achieve that? What do you think about installing Directus with Docker on a Generic Port App?

Thank you for finding and linking the GitHub issues. I had come across one of them, although the “fix” did not work for me.

Happy New Year

P.S. Tried to PM but am not allowed.

Hello @tomkenkel,

To update the database-related settings for your project, go to “Deployments,” then navigate to “Deployment Workflow” and click on “Environment.” Modify the necessary variables related to the database.

Remember, changes in these settings only take effect after a redeployment. As the 1-click setup doesn’t automatically configure a repository for your workflow, make sure to set up a repository. After that, you can perform the deployment to apply the changes you made to the database settings.

If you want to setup a new project, you can perform the following set of activities:

  1. Create a new Directus site without enabling the “Setup Database” option. This ensures you get the default setup instead of a fully configured Directus app.

  2. In the deployment workflow, configure the code repository settings. If you don’t have a Directus project yet, you can fork our default repository at GitHub - cleavr/cleavr-setup-directus.

  3. Once the repository is set up, update the environment variables with the required values. This step involves providing the necessary information for your Directus project to work correctly. In this case add Supabase details.

  4. Trigger the deployment process. This step activates the deployment of your Directus site with the updated configurations and environment variables.

I hope that helps. Please let us know if you’ve any other issues or questions. We’re here to help.

Thanks again @anish ,

I’ve tried a few things with no luck. To note:
I have tried the steps above multiple times (using the cleavr default repo).
I have tried using the “1-click” Directus install (that works as expected) and copying all ENV vars to a site without the Setup Database option (changing domain and port vars).

The deployment steps all show “completed”, but the deployment consistently errors out.


2024-01-12T01:08:17: PM2 log: App id:13 disconnected 2024-01-12T01:08:17: PM2 log: App [] exited with code [0] via signal [SIGINT] 2024-01-12T01:08:17: PM2 log: Script /home/repo/ had too many unstable restarts (16). Stopped. "errored"

Got it working with Supabase by using the 1-Click install and reloading the ENV with new variables for Supabase.

I was getting a 502 Bad Gateway error — PM2 logs pointed out that Directus tables were not set up.

Using Docker on the local computer, I config’d a new Directus with the same ENV vars to quickly create those tables.

The 502 error resolved and things are working as expected.

This process is hacky but I was never able to get the recommended steps to work. I hope Cleavr will look into it!

Thanks for the help.