Deploying strapi results on error

I keep encountering this issue when i tried to deploy strapi v3 on clever nodejs using github actions and i get this error below

Copy Project 20220224073356666
Cloning carlmac/ca-v3-portal-st:main to /home/cleavr/
Linking /home/cleavr/ to /home/cleavr/
Fetching build artifact URL from carlmac/ca-v3-portal-st
Fetching download artifact URL from carlmac/ca-v3-portal-st
curl: (3) URL using bad/illegal format or missing URL

not sure what this is?

please note file above has been sanitised for the company and project anonymity

Hello @Karlomac01,

Does there happen to be an error on the GitHub Actions side for the build? Check the ‘Actions’ tab in GitHub on your code repo.

I just tried deploying a Strapi app via GH Actions and was successful. I’m hoping there is an error on the GH side that provides more context.

there was no error shown however when i opened the upload artefact it seems to not find any – also im not sure if its even generating an artefact from the previous step.

Hello @Karlomac01 ,

It looks like you’ve a Cleavr Lite subscription and we don’t support GitHub Actions Integration with lite subscription.

Can you please clarify a few things: are you sure you are using GHA Integration provided by Cleavr? Were you able to see the UI that I’ve attached below or Pro Subscription Required banner?:

And I’m not sure but this might have happened: You’ve a lite subscription but you were able to enable GHA Integration (could be a bug if that’s the case).

Oh - im using a new trial for my client - its on a 7-day trial only. Trying to prove cleavr is the best to use to deploy strapi and nuxt app combo… unfortunately, its not really working out too well –

I managed to deploy on github actions and all looks ok by the PM2 logs but i cant access it using the allotted domain:

Can you send me a PM with the email of your trial account so that I can look into it?

ok sent you PM.

I tried to re-create a new site where i have DNS control – now i encounter the error below:

Your previous site has 502 error and doesn’t have issues with GHA Integration. Please check the following documentation on how to debug 502 error: NodeJS Deployments Troubleshooting - Cleavr docs

Specially for Strapi apps: NodeJS Deployments Troubleshooting - Cleavr docs

[UPDATED] Can you also try re-creating a new site?