Deploy problem using Hetzner VPS

I’m trying Hetzner for VPS and i cant Deploy.

I don’t know if the problem is in Cleavr, GItHub or Hetzner.

Don’t get any log in Deploy error and i cant find any other log.

Please advise

Thank you

You said you just moved to GitHub? GitHub recently changed it so the default new branch is main instead of master. Can you double check? Also,can you reauthenticate your GitHub authentication profile again?

My branch is master and i have reauthenticated and Cleavr finds the repo in Web Apps settings so thats all good.

But i think the problem is when Cleavr tries to move files from GitHub to the Hetzner VPS.

I have done exactly like i did using DO but it won’t work.

Tried another repo/app and same problem. Must be some problem writing the repo files to Hetzner

We are looking into it.

1 Like

Remember that permission issue that I was talking about? It looks like there was an issue during server provision and caused a folder’s permission not to be set properly (we’ll keep digging more into it). But try it now, and you should be able to go beyond the copy project step.

1 Like

Yey, now it works.

I also tested an Flash Deploy to a new server and that worked.

Thank you so much. I thought i did something wrong but i couldn’t figure out what :slight_smile:

1 Like

I’m glad it worked. There are so many moving parts with server provisioning -> site creation -> ssl installation -> app deployment, that there is a chance something might go wrong and not much we can do.

If it is a new server, it doesn’t hurt to try a new server right away (as it costs fractions of a dollar to provision one) to save some time.

1 Like