Cannot deploy Strapi CMS - Error 502

Every time I deploy my Strapi CMS and I try to visit it I get error 502.

What I did:

-Uploaded the project on github and deployed it
-Added a SQL database to the server and env credentials in Cleavr

What can it be? Do you need additional info?

The server is on port 8787, but Strapi gives the CMS on 1337. Tried to change it(maybe incorretly) but still didn’t work and gave me 502 error.

I think it’s related to the DB

Here is the troubleshooting guide for NodeJS apps:

I did take a peak at your app setup, for the web app > settings > build, try using npm for entry point and start for arguments. I believe yarn used in entry point would also require that the PM2 Ecosystem defines an interpreter for PM2 to use yarn, in which case I would just use npm.

1 Like

Genius, solved it by switching to npm!

1 Like


Are you trying out Stapi v4 by chance? I saw they just released the beta version.

Saw it too! But no, I’m still using the great old one

1 Like