AstroJS Project frozen on "Generate App"

Hello,

Firstly great work on an amazing piece of software. I have been worrying about my move to NodeJS because servers seem difficult to configure. I completely understand Cleavr it works amazingly.

I have deployed my Directus website and that launched completely fine. I’m now trying to deploy my Astro static website that goes with it. However it’s stuck on “Generating App”, I can see in the PM2 access logs that it has hit the right endpoints during the build process, but it seems to be going no further than this.

Does anyone have any ideas on why this could be happening? I did the build locally and it finished in 3 seconds, but Cleavr has been hanging for over 10 minutes.

Thanks,
Tom

Hello @Tom,

First of all, welcome to Cleavr Forum.

We’ll have a look at your issue and get back to you as soon as possible.

Sorry for the trouble caused.

Hello @Tom,

Sorry for the inconvenience caused because of this.

We’re still working on it trying to reproduce the issue so that we can find the cause of the issue and get it fixed.

I hope you understand.

Hi @anish,

Thank you for your quick response. Is there anything I can do on assisting with the bug fixing? For exampling inviting you to the repo?

Thanks

Hi Tom,

This bug has left us scratching our heads. It was getting very very late so Anish went to sleep so I’m jumping in. Having access to the repo would be very beneficial. Can you please send an invite to username ashokgelal on GitHub?

Thanks for your patience and willing to help us fixing this.

Hi @ashokgelal,

I’ve added you to james-lowe which is the repo with the issue and james-lowe-directus which is the headless CMS. This launched fine but I thought it’s best to cover all bases.

Thank you for your effort on this - it’s really appreciated.

1 Like

Great! I’m testing it right away. Be right back (fingers crossed)!

Thank you very much @ashokgelal,

Good luck! Let me know if I need to make any updates my side of things.

Thanks,
Tom

One thing that we have found so far is that some output in the Generate App step is causing it to not trigger the next step. As a work around can you go to Settings > Build and change the Build Command to npm run build --production > /dev/null 2>&1 and see if that makes it move?

This is just a workaround for now but it doesn’t have any downsides so you can use it for as long as you want until we have a more consistent way of reproducing it. Please let me know if it works or not.

@Tom No need for the workaround, we were able to repro it finally and a fix has been deployed already. Let us know if it works for you or not.

Sorry about the issue again. We’ve extended your trial by a week as a sorry for your inconvenience and as a thank you for your help resolving this issue. Cheers!

1 Like

Thank you so much @ashokgelal - I’m telling my friends in the Directus discord community about how good Cleavr is. I’m very impressed, especially with the support.

3 Likes