504 gateway timeout

My site has been down for quite a while with an error 504 gateway timeout error. Is anyone else facing this issue? The uptime monitor and uptime checker sites show that the site is up, but I can’t access it myself.

update: now the down time monitors show it down too

Hello @aay,

We’ve not received any complaints regarding 504 Gateway Timeout Errors recently. I checked one of your sites and the site was up and running on my browser.

DNS Change, Network connectivity, or firewall may also cause 504 errors sometimes.

I have been trying with VPNs and another internet connection too, but I still get an error, apart from that uptime monitors show it to be down too :confused:

Your site is taking too long to load maybe you can also check if there are new changes in the codebase that can make the site slower.

For that, I need to access the site first. Which I am not able to. PS: I constantly get this on the dashboard - image|468x201

The uptime monitor tool that you’ve been using shows your site to be Up and Running now.

We hate to inform this but we do have some issues with Monitoring in that case you can try re-installing monitoring or Repairing the service from the monitoring page.

But the good news is we’ve already worked on the fix for monitoring and it’s in the testing phase. We’ll deploy the changes once we’re done with the test.


Down actually. I can’t check anything without getting to the dashboard.

This is strange but it looks fine on my end.

The uptime monitor sometimes shows your site to be down and the other time it’s up. I think their tool is not able to determine the status since it is throwing a 504 error and that’s the reason why it’s saying down.

I am using uptime robot too, it is too fluctuating between down and up for quite a while, and the site hasn’t load even once for me since I have been checking

I see there are errors on NGINX. You can check it on Server < Logs <. NGINX Error.

I am trying to read it but I don’t think I can understand any of them (not a very techy guy)

No need to worry about it ;).

We can help you with that but it may take some time until we find out what’s going on and come up with a solution.

Yes, sure, but I can confirm an error, I asked someone in a city almost half my country across to access the site, and they still see the gateway timeout I see. Would you please let me know your findings

The Server’s disk storage was full which was causing the issue. So I purged the binary logs created by MySQL before 2021-11-18.

I’ll bring this issue to our next team meeting and see if we could clean such logs periodically.

For anyone else facing the issue you can purge MySQL Binary logs with: PURGE BINARY LOGS BEFORE 'YYYY-MM-DD HH:MM:SS';

is this command used via SSH?

You need to have access to the database. So yes. Or any database tool such as TablePlus will work either. In your particular case, the storage was full due to large MySQL log files so it required to purge the MySQL related log files.

OK Great, this works :slight_smile: Thanks for your help!

1 Like

I remember me that in soms circumstances the bin log files in MySQL 8 become huge. I fixed it by changed the MySQL configuration by disabling bin logging with disable_log_bin